最新消息:大连网龙科技旗下品牌大连网龙互联正式上线!

wordpress全局变量

新闻 高, 高 344浏览 0评论

u=2197005665,3677449946&fm=21&gp=0
  我们在使用wordpress进行主题开发或者插件开发过程中,经常需要调用到wordpress系统的全局变量,比如,post 对象$post,wordpress版本$wp_version,数据库对象$wp_query等,如果我们了解这些对象,大大有利于我们队wordpress进行二次开发。

如果你想在你的代码中访问一个全局变量,首先做的事是把这个变量用global声明下: global $variable;

内部循环变量

在循环中,这些全局变量被设定位储存当前正在处理的页面的信息。

$post 整个 post 对象.

$authordata (object) 返回一个包含关于作者信息的对象,可以显示在文章详情页中。

$currentday 文章发布的日期

$currentmonth 文章发布的月份

$pages (int) 文章post里的页数, 用于分页功能。

$multipage (boolean) 如果post有多个页面,则返回true。与$page以及$pages相关。

$more (boolean) 返回true 如果文章有多篇页面, 与$page以及$pages相关

$numpages (int)返回文章总共的页数, 与$page以及$pages相关

浏览器检测全局变量

如果你需要检查当前浏览器及平台,则需要用到以下全局变量:

$is_iphone (boolean) iPhone Safari

$is_chrome (boolean) Google Chrome

$is_safari (boolean) Safari

$is_NS4 (boolean) Netscape 4

$is_opera (boolean) Opera

$is_macIE (boolean) Mac Internet Explorer

$is_winIE (boolean) Windows Internet Explorer

$is_gecko (boolean) FireFox

$is_lynx (boolean) Lunix

$is_IE (boolean) Internet Explorer

Web服务器检测全局变量

以下为判断当前服务器的信息,好像还没有Nginx的。

$is_apache (boolean) Apache HTTP Server

$is_IIS (boolean) Microsoft Internet Information Services (IIS)

$is_iis7 (boolean) Microsoft Internet Information Services (IIS) v7.x

版本变量

用于检查系统的版本信息:

$wp_version (string) 已安装的WordPress版本

$wp_db_version (int) 数据库版本

$tinymce_version (string) 已安装的TinyMCE版本

$manifest_version (string) cache manifest版本

$required_php_version (string) WordPress要求的PHP版本

$required_mysql_version (string) WordPress要求的MySQL版本

其他

包括一些数据库对象的全局变量:

$wp_query (object) WP_Query类的全局实例.

$wp_rewrite (object) WP_Rewrite 类的全局实例.

$wp (object) WP 类的全局实例.

$wpdb (object) wpdb 类的全局实例.

$wp_locale (object)

$pagenow (string) 在wp-admin中使用

$allowedposttags (array)

$allowedtags (array)

转载请注明:大连网龙互联 » wordpress全局变量

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址